referal problems

Posted in

Hi below is a problem with your plugin as described by my client, any ideas? Many thanks

Bad news: we appear to have a major problem with the affiliates plugin. I went to calculate referral totals for the last 6 months of 2016 and it returned no hits. In fact, the last time it logged a sale against an affiliate was in May 2016. The system seems to be recognising referrals but then not crediting sales to that affiliate. One case I have checked through is order 2974 made on 1st Jan at 20.34. The ‘visits & referrals’ info on the site gives this information:
2017-01-01 20:36:26 65.93.178.90 Helen Stevens
2017-01-01 20:35:35 65.93.178.90 Helen Stevens
2017-01-01 20:35:03 65.93.178.90 Helen Stevens
2017-01-01 20:29:04 65.93.178.90 Helen Stevens
2017-01-01 20:29:02 65.93.178.90 Helen Stevens
2017-01-01 20:27:28 65.93.178.90 Helen Stevens
2017-01-01 20:27:24 65.93.178.90 Helen Stevens
Helen Stevens is the referrer here and the customer then bought her book at 20.34 but no sale is shown and there are no hits for referral totals for this time.

I tried putting through an order this morning using Julia Bremble’s link. The system recognised the referral from her but showed the sale as ‘direct’ (although this may be because it was on Vivienne’s computer so it didn’t continue to recognise the referral). So I checked through the order 2974. Since that is shown as coming from Helen Stevens and the customer ordered, there should be something in the totals – but nothing!

This also means we have a major problem in calculating money due to affiliates since May. I’m struggling with the notion of manually checking every sale since then against the referrals listing . . .
Any ideas? It looks like an update b8ggered something slightly but it isn’t obvious.

11 Responses to referal problems

  1. George January 3, 2017 at 11:10 am #

    Hi doynie,

    Can you provide temporary admin access to the site?
    I would like to review the configuration of the plugin so that we can work out the issue.
    You can send the account details to george at itthinx dot com and mention the topic title on the subject.

    Kind regards,
    George

  2. doynie January 3, 2017 at 11:45 am #

    Hi George,

    Admin login sent to you.

    Many thanks

  3. George January 3, 2017 at 8:47 pm #

    Hi doynie,

    Thank you for sending the account info.

    Your settings seem to be correct.
    However, there seems to be an issue with your Affiliates WooCommerce Integration. The settings page is missing information and particularly the Product rate section.
    I would suggest you to delete this integration and reinstall.

    There is also another possibility that your caching plugin might block the affiliate url, but it doesn’t provide any options to ignore url parameters.

    So, at first try reinstalling the integration and notify me.

    Kind regards,
    George

  4. doynie January 4, 2017 at 9:53 am #

    I don’t think I set this up myself, the client did, but where can i find product rate? I can’t see it under the settings.

  5. George January 4, 2017 at 11:32 am #

    Hi doynie,

    Default product rate section appears in the Affiliates WooCommerce Integration, and under Products > Edit Product under Product data. You can have a look in the documentation screenshots of the plugin.

    Cheers

  6. doynie January 4, 2017 at 1:04 pm #

    Hi George, see the response from my client below:

    “Will a reinstall mean that all referral rate and the affiliates and links have to be done again?? Obviously, it important that the referral links stay the same because a whole load of authors have those links in their own websites. I do have a copy of all the links (attached) so you can see how much is involved. Clearly, I’m not very happy about a response that takes it no further than you and I had already been able to do. Why did it stop working in the first place? Unless they have some idea of why, a reinstall is just a scattergun approach?”

    He has a point, surely we are better of trying to get this existing instal working, I’m more than happy to dissable any caching (or anything else) to see if that is the issue, clearly reinstalling all the referal links would be a massive pain

  7. George January 4, 2017 at 7:48 pm #

    Hi doynie,

    By deleting and then reinstalling Affiliates WooCommerce Integration will not affect Affiliate Data.
    The re-installation is needed to ensure that the integration is not broken.
    As i mentioned before, your copy of Affiliates WooCommerce Integration is missing features. The documentation link i provided contains screenshots of how would a normal installation look like. In your case, you are missing the options for Product default rate and individual product rate option. So, in order to ensure that you don’t have a broken/malfunctioning copy of the plugin installed, i would recommend you to delete Affiliates WooCommerce Integration and reinstall it.
    If the integration is not broken, we will move forward to disable the caching and/or the security plugin you are using.

    For your own safety, you can always take a full backup of your site files and database, or you can create a staging copy of your site to avoid modifying your live site.

    Cheers,
    George.

  8. doynie January 11, 2017 at 9:41 am #

    Hi George,

    Ok understood, but where do I download a new copy of Affiliates WooCommerce Integration? I can’t see it in my downloads, and I can only find a download link for the ‘light’ version?

  9. George January 11, 2017 at 11:45 am #

    Hi doynie,

    It can be installed through your Dashboard. Visit Affiliates > Settings under the Integrations tab.

    Cheers,
    George

  10. doynie January 17, 2017 at 5:51 pm #

    Hi George,

    The Affiliate woocommerce integration has been re-installed and setup as per the documentation but unfortunately is still not working.

    Please advise.

    Thanks

  11. George January 19, 2017 at 3:20 pm #

    Hi Doynie,

    I think it’s better if i have a look at your configuration.
    You can send me temporary admin access to george at itthinx dot com.

    Cheers,
    George