affiliate pretty links getting 404 not found

Posted in

I am getting a 404 page when I click on one of my “pretty” affiliate links. The regular links work fine but I have given out some of the “pretty” links to my affiliates. Here are the two links for an affiliate so you can see for yourself.

5 Responses to affiliate pretty links getting 404 not found

  1. Lindsay May 21, 2014 at 2:11 am #


    I’ve tried all of the above mentioned methods, though no matter what is done my links still appear in the query form with the username ( instead of with the pretty links (

    Is there something additional needed to be done to activate pretty links for the affiliate URLs?

    I noticed in a few other related threads mentioning errors with Pretty Links…what errors should I look for in the log?

    Thanks 🙂

    • kento May 23, 2014 at 12:23 pm #

      Hi Lindsay,

      Pretty affiliate links have been deprecated since 2.6.0 – please use the URL parameter links instead.


  2. Fuyuko April 2, 2014 at 11:23 am #

    Hi I’m having the same issue with pretty links. Redirect workswith query string attached. but with pretty links, it’ll go to 404 page.

    I have tried the above suggestion (changing “redirect” in affiliates->options and settings->permalinks “save changes” in each setting)

    • antonio April 7, 2014 at 10:29 am #

      you can try changing your Affiliate URL parameter name (in Affiliates->Options) to another that not be suffix of slug page.

  3. antonio November 23, 2013 at 6:06 pm #

    Please try:
    – On Affiliates->Options select if not selected or vice versa “Redirect”.
    If this doesn’t work, try on Settings->Permalinks “save changes” to regenerate htaccess file.


We use cookies to optimize your experience on our site and assume you're OK with that if you stay.
OK, hide this message.

Affiliates · Contact · Jobs · Terms & Conditions · Privacy Policy · Documentation · Downloads · Useful Plugins · My Account