Deosn’t show products / request log in

I have installed the latest version on my clients website:


When the client logins in to view products in his category they get the error message: “Please log in to view your corporate sign range.”
this happens when logged in. We have tried it and we get the same message so appears to be doing for all clients.
An example product is

this has previously worked OK

8 Responses to Deosn’t show products / request log in

  1. George September 4, 2019 at 5:29 pm #

    Thanks Philip, that would do.
    We are always going after such cases so that we can keep track and resolve similar requests more easily.


  2. George September 3, 2019 at 12:34 pm #

    Hey Philip that’s great, good to know you resolved it.
    For the record how was this message generated so that we can keep your feedback for similar requests in the future?


    • Philip Levy September 4, 2019 at 9:21 am #

      Hi – not sure what you mean by how was this message generated? Do you mean how was it resolved? If so we found that actually it was down to some bespoke code on the website that stopped products with zero pricing from being displayed. It just so happened that many of the custom signs they make have a zero price because each order is priced according to qty etc so it looked like the plugin wasnt working when it was the code !

  3. Philip Levy September 2, 2019 at 2:44 pm #


    thanks for your help in confirming this wasnt a plugin issue from you – sorry you had to do the work but eliminating this has helped find the root cause and it is now resolved!

    Thanks for your help

  4. George August 30, 2019 at 10:29 am #

    Thanks Philip,

    I’ve checked your site and the message appearing is not related to Groups or Groups Restrict Categories. There are two options when it comes to Groups and restrictions, the user has access and can see the content or the user doesn’t have access and gets a 404 not found.

    I would recommend you to temporary disable Groups and Groups Restrict Categories and try to access that category. The message is probably related to another plugin which manages user access, or even to the product category template. If not sure which one might be, you should check the recently added/updated plugins. Otherwise, you can deactivate all your plugins apart from WC, Groups and Groups Restrict Categories and then start activating them one-by-one until you spot the one producing this message.

    Kind regards,

  5. Philip Levy August 30, 2019 at 9:40 am #

    Hi – any news yet? Thanks

  6. Philip Levy August 29, 2019 at 2:01 pm #

    thanks – just set you up George

  7. George August 29, 2019 at 12:45 pm #

    Hi Philip,

    Sorry to hear that.
    I think it’s better to have a closer look at your website and setup. Please provide us with a temp admin account which should also be a member of the group which has access to the category you mentioned on your request.
    It will also be useful if you enable debugging in case there is something logged there related to the issue.
    You may send the user account credentials to george at itthinx dot com.

    To enable debugging, edit your wp-config.php file and do the following:
    Replace this line: 

    define( ‘WP_DEBUG’, false );

    with these lines:

    define( ‘WP_DEBUG’, true );
    define( ‘WP_DEBUG_LOG’, true );
    define( ‘WP_DEBUG_DISPLAY’, false );

    Kind regards,

We use cookies to optimize your experience on our site and assume you're OK with that if you stay.
OK, hide this message.

Affiliates · Contact · Jobs · Terms & Conditions · Privacy Policy · Documentation · Downloads · Useful Plugins · My Account