problememm with Re-captcha

Posted in

Hi, I read about problem in this forum and did as but on the page https://harchi.kiev.ua//affiliate-area/ new user can’t born. Write “You recaptcha is wrong” captcha v2

8 Responses to problememm with Re-captcha

  1. Denitsa March 14, 2019 at 10:25 am #

    Hello,
    1) It’d be better if you contacted BestWebSoft for support regarding their plugin, as they are best equipped to solve issues connected to it. Their Help Center page can be found here -> https://support.bestwebsoft.com/hc/en-us
    2) The Subscriber role is automatically assigned by WordPress when a new user registers on your website, regardless if it鈥檚 affiliate or not. This can be changed by going to WP Dashboard > Settings > General and choosing from the dropdown next to the field labeled New User Default Role. Again, this changes the role ALL users are assigned when registering to your site, not just affiliates.
    Alternatively, we have an extension that will add the ‘Affiliate’ role to newly registered affiliates. You can get it here -> https://github.com/itthinx/affiliates-role
    If you want to substitute the user’s role, rather than just add the Affiliate role, comment out the line that says
    $user->add_role( 'affiliate' );
    and uncomment
    //$user->set_role( 'affiliate' );
    If you’d like to add a different role, then you can use the extension’s code as a reference – you’d change the ‘affiliate’ parameter in the brackets with an existing user role, or create a new one using the activate() function and substituting CUSTOM_ROLE_SLUG and CUSTOM_ROLE_NAME with your desired ones.
    public static function activate() {
    add_role( 'CUSTOM_ROLE_SLUG', 'CUSTOM_ROLE_NAME', array(
    //Set the role capabilities here!
    'read' => true,
    'edit_posts' => false,
    'delete_posts' => false
    ) );
    }

    A reference on user capabilities that need to be set as the third function argument can be found here -> https://codex.wordpress.org/Roles_and_Capabilities
    Cheers,
    Denitsa

    • stanistar March 14, 2019 at 2:28 pm #

      hI Denitsa,

      I test just now how it work, me important change status in woocommerce,

      Where I can change % comission for affiliate?

      Is it possible help me by email, no public chat?

      • Denitsa March 14, 2019 at 5:41 pm #

        Hello,
        You can change the commission rate, as well as the preferred commission method, by going to Affiliates > Settings > Commissions tab under the Value field.
        We can continue the conversation by email if you’d prefer 馃檪 Email us at help [at] itthinx [dot] com , I’d be glad to help you out further.
        Cheers,
        Denitsa

  2. Denitsa March 13, 2019 at 10:37 pm #

    Hello again,
    I’ve removed your comment containing the screenshot, since it contained your email address – please make sure to hide sensible info when posting on the forums.
    You can only use reCAPTCHA v2 with the Affiliates reCAPTCHA plugin – you have that one installed, correct?
    Cheers

    • stanistar March 13, 2019 at 10:49 pm #

      No, no Affiliates reCAPTCHA -. Google Captcha (reCAPTCHA) by BestWebSoft

    • stanistar March 14, 2019 at 1:38 am #

      Hi, tested please)

      1) I use invisible google captcha for other form but together with plugin (reCAPTCHA) by BestWebSoft ver 2 or ver 3 don’t work.
      Only work if setting (reCAPTCHA) by BestWebSoft captcha use invisible.

      2) Possible, after affiliate registration, give him another role? No Customer. I want choise it.

  3. stanistar March 13, 2019 at 9:42 pm #

    Can I use ver3 google captcha or only ver2?

  4. Denitsa March 13, 2019 at 7:58 pm #

    Hello there,
    I’m guessing you mean that you’ve read and followed the instructions in this post -> https://www.itthinx.com/topic/recaptcha-not-allowing-registration-on-our-site/#comment-908748 ?
    I visited your page and there are a couple of errors in the console, see screenshot here -> https://pasteboard.co/I5h1GHF.png
    Did you double-check that the keys are pasted correctly and the domain name does not have http:// or https:// when in the Google dashboard? It’d be great of you could make a screenshot of the settings for reCAPTCHA in your Google account and upload it somewhere for us to see. Please make sure to hide any sensible information (email, keys, etc), you can use the below example as a reference:
    https://pasteboard.co/I5h61dO.png
    Cheers,
    Denitsa

Only authorized members can comment on this topic.

Log in

Share