Can’t import from one site to another, Invalid file_id

We exported GFA files (and export text file) from one site and attempted to import them on another site.

It’s the same result whether I run it as a test or not. No files are imported.

I inspected the file in a text editor and in LibreOffice, tried saving it as a CSV from LibreOffice, still doesn’t work. The import process thinks the file ids are “invalid”, but I can’t see why.

Results after importing (test only) from groups-file-access-export-2022-06-27-12-08-16.csv :

0 files would have been imported

202 invalid lines were detected

Invalid lines: 1, 2, 3, 4, 5, 6, 7, 8, 9, 10…

1 : Invalid file_id 1

2 : Invalid file_id 19

3 : Invalid file_id 21

4 : Invalid file_id 25

5 : Invalid file_id 26

6 : Invalid file_id 30

7 : Invalid file_id 31

8 : Invalid file_id 32

9 : Invalid file_id 37

10 : Invalid file_id 38

4 Responses to Can’t import from one site to another, Invalid file_id

  1. George June 27, 2022 at 9:40 pm #

    Hey Steven,

    This happens because the file_id entry of your old site won’t match the file_id entry of your new site.

    Since the files are in the correct location, first edit your import file and remove the file_id entry which is the second column right after the filename, leaving it empty. The file_id will be auto-populated to your new site without issues.

    Save this file and then try to import it again as a Test only or proper import. In general the import file can even be a .txt file.

    Kind regards,

  2. Steven June 27, 2022 at 5:55 pm #

    They are in /public_html/wp-content/uploads/groups-file-access on both sites

  3. Steven June 27, 2022 at 5:54 pm #

    The files were in fact uploaded to the correct directory before the import attempt.

  4. George June 27, 2022 at 5:23 pm #

    Hi Steven,

    Sorry to hear that you had issues while trying to import your file data.

    From your description I’m assuming that you haven’t uploaded your files in the managed folder as mentioned in the documentation for Importing files.

    Once you have a look at the link above and if indeed this is missing point, proceed first with the file uploading and then try to import your file data via your import file again.
    Please let me know if your problem persists.

    Kind regards,

We use cookies to optimize your experience on our site and assume you're OK with that if you stay.
OK, hide this message.

Affiliates · Contact · Jobs · Terms & Conditions · Privacy Policy · Documentation · Downloads · Useful Plugins · My Account