14 Responses to Issues with Adding Users Manually and Affiliates Login

  1. George October 24, 2016 at 5:15 pm #

    That’s great!
    Thank you for your cooperation. 🙂


  2. Anthony October 24, 2016 at 12:40 pm #

    Perfect. We are good to go from here.

    many thanks for your patience and assistance!


  3. George October 24, 2016 at 10:22 am #

    Oh i see.

    Then you should use these shortcodes:

    Kind regards,

  4. Anthony October 24, 2016 at 5:33 am #

    Hi George,

    Thank you. we are using the affiliates by username plugin. This was purchased for another site that we are also using your pro version on via the web developer working on that site. He has disappeared and we do not have his login details for your site so have had to create a new account.

    The username plugin is working perfectly – adding commissions correctly etc. I was just wondering if we could show the username link in the affiliates area instead of the standard one please.

    currently it still looks like this:

    Your affiliate URL:

  5. George October 23, 2016 at 8:25 pm #

    Hi Nicole,

    Please make sure you are running reCaptcha plugin with the equivalent Affiliates reCaptcha and not Captcha plugin and Affiliates reCaptcha for example. Also, have a look under Settings > Affiliates reCaptcha to make sure that the keys match the keys on your Google account.

    Regarding affiliates links with usernames, as i mentioned you before, you need Affiliates by Username extension.

    Kind regards,

  6. Anthony October 22, 2016 at 10:27 am #

    Ah – I have uploaded and actived affiliates recaptcha – no captcha form appearing on affiliates login area.

    Page redirecting to wp-admin login when correct details are entered – due to site recpatcha plugin.

    What do I need to do to get them to work together please.

    Site key and secret key entered correctly.

    With thanks,


  7. Anthony October 22, 2016 at 8:17 am #

    Hi George,

    All up and running beautifully.

    Many thanks for you assistance 🙂

    Final question please? – how do we show the affiliate link with the username in the affiliates area please?

    With thanks,


  8. George October 21, 2016 at 1:37 pm #

    You are welcome Nicole.

    Affiliate captcha is a Captcha plugin integration for the affiliates registration form.
    For wp-admin the Captcha plugin would be applied.

    If you are not using the Affiliates by Username addon then the affiliate process will only work for the usual affiliate link.

    The coupon might work universally on your e-commerce aka grant discount to the customer, but the referral and commission will be granted to the affiliate with that coupon attribute. Please make sure that you have installed the proper integration for your e-commerce plugin. You can see the complete list here.


  9. Anthony October 21, 2016 at 5:46 am #

    Hi George,

    That’s very helpful – thanks!

    Does the captcha plugin add captcha to the wp-admin form as well please?

    I have added the username to the affiliate successfully. I did a test purchase via eft – marked the order as complete.

    The affiliates admin panel shows the hit, but doesn’t add the commission for the affiliate.

    The test purchase was for ZAR 0.95 – the commission is set to 10% – the coupon is working but it is working universally and not just on the affiliate link – I would like a specific coupon to only work for a specific affiliate please.

    I really appreciate your assistance 🙂

    With thanks,


  10. George October 20, 2016 at 9:39 pm #

    Hi Nicole,

    In order to use the username in the affiliate url you should buy the Affiliates by Username addon.

    Regarding recaptcha you should have a look at Affiliates reCaptcha plugin which is available for free.

    Regarding the paragraph above the login form, you can use the shortcode [affiliates_is_affiliate]
    and the shortcode [affiliates_is_not_affiliate]. With these you can show/restrict content to affiliates or non-affiliates. Another example of these shortcodes can be found in your Affiliate Area page, edit it and have a look at the contents.

    If you need further assistance with any of the above you can always ask here.


  11. Anthony October 20, 2016 at 4:58 pm #

    Hi George,

    Second prize would be to have a paragraph above the login form that also disappears if the user is not an affiliate.

    First prize would be that the user is redirected to another page (I can add a contact form for them to apply here) if they are not an affiliate but are a user.

    we are only added affiliates via admin at the moment.

    With thanks,


  12. Anthony October 20, 2016 at 4:43 pm #

    Hi George,

    Google Recaptcha causes the same issue. I would really like to keep recaptcha on the site login forms. Is there any way around this please?

  13. Anthony October 20, 2016 at 4:32 pm #

    Hi George,

    Many thanks for the information.

    I have it working now. What was happening is that it was logging in as user – but user wasn’t linked to an affiliate so it was just showing the become an affiliate message again and removing the login form because the user was a valid user – but not displaying the affiliate information because the user was not an affiliate – is there any way that we can reload the page if it is a valid user that is not an affiliate to show the login form still please? (I hope this makes sense!)

    We had a plugin that was messing with the login as well – it was redirecting to the wp-admin login page for the user to enter the captcha but then obviously opening up the my account page instead of the affiliate area. (Captcha by BestWebSoft) – Iahev deactivated it and am now able to access the affiliate page correctly.

    I will test the coupon now. I have added one as an attribute with thanks.

    Please can you advise on how to user the username in the affiliate url – I am hoping that we do not have to buy an addon to do this?

    With thanks,

    Nicole (developer for Anthony)

  14. George October 20, 2016 at 1:00 pm #

    Hi Antony,

    Does the shortcode render properly on other browsers?
    You are right about lost password, but once the user enters a wrong password is redirected to wp-login page where he/she has that option.
    When you add affiliates manually, they don’t exist as users. If on the other hand, you first create a user and then create an affiliate for this user, then the affiliate will use that password.
    In order to add a coupon per affiliate, you can add this as an attribute. Please follow the instructions at the documentation.

    Kind regards,

We use cookies to optimize your experience on our site and assume you're OK with that if you stay.
OK, hide this message.

Affiliates · Contact · Jobs · Terms & Conditions · Privacy Policy · Documentation · Downloads · Useful Plugins · My Account