Referrer User Shortcode Question

Hi,

We’ve been using the referrer_user shortcode in the footer of our store so customers could see the email of the person referring them. Recently it stopped working. Here’s the shortcode we were using: [[referrer_user]

Looking over the docs, I see that the proper shortcode to use is: [referrer_user direct="true" display="user_email"]

But when I test this using an affiliate link: [https://inlight4vets.com/?associates=39 the shortcode isn’t displaying the email on the store page: https://inlight4vets.com/store/ in the middle part of the footer.

The pages where this is being displayed are excluded from the cache.

9 Responses to Referrer User Shortcode Question

  1. antonio March 15, 2017 at 8:12 pm #

    Hi David,
    Please check if your affiliate has a wordpress user associated (from Affiliates->Manage Affilaites)
    If he has an user, please say me how are you using the shortcode.
    Kind Regards,
    Antonio B.

  2. David March 16, 2017 at 2:44 pm #

    Yes, there’s an affiliate with that link I gave. The email you should see in the footer is [edited].

    Like I said, we were using [referrer_user] but that stopped working. I read the docs and tried [referrer_user direct="true" display="user_email"] but that isn’t working either.

    • antonio March 17, 2017 at 7:18 am #

      Hi David,
      I have tried to use this shortcode and it works well.
      I can see that you aren’t using the shortcode on the page content. How are you running the shortcode on a widget?
      Kind Regards,
      Antonio B.

  3. David March 17, 2017 at 3:27 pm #

    HI Antonio,

    Yes, its running in a widget.

    • antonio March 20, 2017 at 7:59 am #

      Thanks,
      By default shortcodes are not executed on widgets. I have tried with this plugin, and I can see the referrer email correctly on my widget area.
      Kind Regards,
      Antonio B.

  4. David March 20, 2017 at 2:47 pm #

    Like I said earlier, this was working (for many months actually) and now it’s not.

    We’ve already activated shortcodes in widgets with add_filter('widget_text','do_shortcode'); so that isn’t the issue.

    • antonio March 21, 2017 at 8:51 am #

      Hi David,
      Using your code I can see my affiliate’s email correctly. Maybe are your widgets cached? You can try to disable your cache plugin.
      If the problem persists, you can send me dashboard admin access to antonio[at]itthinx[dot]com indicating this topic and I’ll have a look at this.
      Kind Regards,
      Antonio B.

  5. David March 21, 2017 at 6:11 pm #

    Thanks. We have server level caching with WPEngine and they have assured me that caching is off for the pages where we use this. Plus, this just stopped working a couple of weeks ago. Until then, it was working.

    I’ve send admin access via your email. It has the subject line ‘Inlight Admin Access’

    • antonio April 7, 2017 at 10:02 am #

      Hi David,
      Sorry, I did not know who that email was.
      It seems to work correctly, I have emailed you.
      Kind Regards,
      Antonio B.