Using Non-existent Affiliate Links Causes Issues

Posted in


Weird problem we’re having: When you used an affiliate link that doesn’t exist, the site is displaying the ‘Hello World’ post instead of the front page.

For example:

Using the other affiliate codes, the site loads correctly.

13 Responses to Using Non-existent Affiliate Links Causes Issues

  1. George July 21, 2016 at 4:29 pm #

    Can you please reset the password for the staging site?
    The oneshare link is no longer available.


  2. George July 21, 2016 at 3:23 pm #

    Thanks David.
    I’ll test the installation there and let you know.

  3. David July 21, 2016 at 1:11 pm #

    Here’s the staging site:

    You can use your login to gain access. Just cllick ‘I Understand’ on the popup and it’ll disappear for a couple of weeks.

  4. George July 20, 2016 at 9:37 pm #

    Thank for the feedback.

    Yes that would be great if you can prepare a staging site.

    Please let me know once it is ready.


  5. David July 20, 2016 at 2:47 pm #

    Never installed WPML.

    I activated the 2016 Theme and deactivated all the plugins except Affiliates Enterprise and got the same results: entering a non-existent affiliate loaded the posts page while an existing affiliate went to the home page.

    I then deactivated Affiliates Enterprise and entered the non-existent affiliate url and it went to the home page instead of the posts page.

    The problem seems related directly to the Affiliates Pro plugin somehow.

    If you want, I can create a staging site where you can troubleshoot the problem directly?

  6. George July 20, 2016 at 11:13 am #

    Thanks for providing admin access David.

    Did you ever use WPML plugin on your site?
    Also, try disabling all plugins and then repeat the test with a non-existing affiliate url, each time by activating them one-by-one.

    After finishing this test and if you don’t find the conflicting plugin, try switching to a default theme like twentyfifteen and repeat the test.

    Once you have checked these, please let me know the results.


  7. David July 19, 2016 at 9:01 pm #

    Must have put in your address incorrectly. Just send you new info from my personal account ddabney at griffinassoc dot com.

  8. George July 19, 2016 at 11:24 am #

    Sorry, but i haven’t received a mail yet.
    Can you please resend it?


  9. David July 18, 2016 at 3:07 pm #

    Just added you as an admin user. You should have a notification in your email now. Thanks!

  10. George July 16, 2016 at 8:56 am #

    I would like to have a look at your dashboard.
    If this is a live site, i suggest you to take a full backup of your files and db and then send me admin access to george at itthinx dot com.

    What is your setting for affiliate cookies timeout?


  11. David July 15, 2016 at 5:30 pm #

    FYI, you can fill in anything on the popup form, submit it and you won’t see if again soon. I’ve disabled the popup plugin and tried the test again and there’s still an issue.

  12. David July 15, 2016 at 1:55 pm #

    Hi George,

    I changed the changed the affiliate parameter to ‘test’ and found the same result.

    Interestingly, while it still went to the ‘Hello World’ page for the non-existent affiliate (test=50), the home page did load correctly for an existing affiliate (test-13).

    Same results when I changed the parameter back to ‘affiliates’.

  13. George July 15, 2016 at 8:56 am #

    Hi David,

    Please change the affiliate URL parameter under Affiliates > Settings > General. Make a test with the new affiliate parameter and see if it works. Then revert back to your old affiliate url parameter.

    Kind regards,

We use cookies to optimize your experience on our site and assume you're OK with that if you stay.
OK, hide this message.

Affiliates · Contact · Jobs · Terms & Conditions · Privacy Policy · Documentation · Downloads · Useful Plugins · My Account