Broken Links After 2.0 Installed

I had Group File Access version 1.6 before today. I purchased the paid version 2.0, downloaded, but could not get it installed through WordPress and not via FTP properly. Before I started I made a backup of the plug-in directory. Then I deleted the plugin from WordPress, added it back like a new plug in.

I didn’t upgrade the Groups plug-in so it is unchanged. I’m using Groups 2.1.1. When I go to Groups\Files, I see all the files I had there before this change. However, none of the links now work.

How do I fix this without changing all those links? I have hundreds of them. Maybe there’s a way to refresh the links without changing their numbers?

5 Responses to Broken Links After 2.0 Installed

  1. George April 21, 2022 at 6:10 pm #

    Furthermore, regarding the URLs of files after you moved to the new server and if they have changed, you can fix the file paths if necessary using the process described in the plugin documentation under the section Moving to another Server:

    However, before proceeding with the query mentioned, make sure to take a full backup of your site files and database.

    Kind regards,

  2. George April 21, 2022 at 10:57 am #

    This is indeed pretty weird, because the error you get indicates an issue with size, but the error you get
    Not Found The requested URL was not found on this server.
    indicates that either the URL is not correct(the new server is using a different folder structure) or something else that I can’t figure out without checking it on-site.

    I think it would be better to have a look at your Dashboard, preferably on a staging clone so that we can avoid interfering with your live site. For the staging clone it would also be useful if you enable WP Debugging. Once you have created the staging clone, you can send us temp admin credentials either in your comment, or use my personal email address for that purpose, george at itthinx dot com.

    Kind regards,

  3. Daisy Brown April 20, 2022 at 8:17 pm #

    This plugin stopped working when Godaddy moved us to a different server. The move was unexpected and not by our choice. Other plugins are okay but not this one. The links stopped working after that Godaddy move. I was going to reinstall the plugin but found that since it was first installed, you are not charging for the plugin. I purchased, downloaded, backed up old, and installed it. That brings us to this point.

    When you click on a link now with 2.0, it gives you: Not Found The requested URL was not found on this server.

    In WordPress \ Groups \ Files, the files are all there. The links from there give the same error. When you look at the list of files, the Size and Date are followed by ERROR.

    Today I went to a file on the Groups\ Files list, click edit and tried to reupload the file. I thought maybe by doing that it would at least fix the Size and Date errors. I’d rather have a different way to get the links to work but if I must upload them one at a time to fix the problem, then that’s what I’ve got to do.

    When I tried to do that upload/replace, I got the error: “413 Requested Entity Too Large followed by a link.” We didn’t have a size problem before changing to 2.0. More than half the files are quite large video recordings.

    So I tried that again, this time with upload/replace through Groups \Files – edit. When I did that, I got this error (location and name replaced): “The file /[location]/wp/wp-content/uploads/groups-file-access/[file name].pdf already exists but it is not related to this entry. The existing file is not replaced and the current file for this entry is maintained.” It is the same file. Same file name.

    Now what am I to do?

    • Daisy Brown April 21, 2022 at 12:54 am #

      With Godaddy assistance, I adjusted the max file size limit in PHP. ******* I still get the 413 error when I try to upload from editing in plugin.

      -edit: removed sensitive data

  4. George April 20, 2022 at 10:17 am #

    Hi Daisy,

    Welcome to our support forum and many thanks for using our plugin on your site.

    When you mention that none of the file links now work, what do you mean? What do you get when you try to visit one of these links, is it a permission denied, file not found or page not found?

    In general and beyond this support request, it’s always good to backup all your files and database because backing-up only the plugins folder is not enough, you need a complete backup of your site that can be used to restore to a previous working version.

    Kind regards,

We use cookies to optimize your experience on our site and assume you're OK with that if you stay.
OK, hide this message.

Affiliates · Contact · Jobs · Terms & Conditions · Privacy Policy · Documentation · Downloads · Useful Plugins · My Account