Deprecated: contextual_help

Posted in
Tags

Hello,

I would like to turn your attention to a deprecation warning showing up since WordPress 5.4 that is flooding the error.log and is visible in the admin. We’re hoping that you can fix this in the upcoming release.

Culprit is add_action(‘contextual_help’, …) within affiliates-pro/lib/core

Thank you and best regards.

5 Responses to Deprecated: contextual_help

  1. George April 21, 2020 at 11:17 am #

    Hey Daniel,

    FYI, we have already released an update for Affiliates plugin, version 4.6.0 which addresses that issue.
    Thanks again for pointing that out, we really appreciate it.

    Kind regards,
    George

  2. George April 4, 2020 at 7:01 pm #

    Hi Daniel,

    Indeed it does use it, I totally missed it here and many thanks for pointing that out.
    We should definitely remove the deprecated hook and update.

    Cheers,
    George

    • philippaar April 8, 2020 at 1:57 pm #

      Hey George,

      thank you.
      Looking forward for the fix 馃檪

      Cheers!

  3. philippaar April 3, 2020 at 3:43 pm #

    Hi George,

    I’m afraid the log is not that helpful, but here you go:
    [03-Apr-2020 15:37:30 UTC] PHP Deprecated: contextual_help is deprecated since version 3.3.0! Use get_current_screen()->add_help_tab(), get_current_screen()->remove_help_tab() instead. in /Users/manou/manou.io/projects/LBWWW/lbwww-new/app/public/wp-includes/functions.php on line 5088
    [03-Apr-2020 15:37:30 UTC] PHP Stack trace:
    [03-Apr-2020 15:37:30 UTC] PHP 1. {main}() /Users/manou/manou.io/projects/LBWWW/lbwww-new/app/public/wp-admin/admin.php:0
    [03-Apr-2020 15:37:30 UTC] PHP 2. require_once() /Users/manou/manou.io/projects/LBWWW/lbwww-new/app/public/wp-admin/admin.php:234
    [03-Apr-2020 15:37:30 UTC] PHP 3. WP_Screen->render_screen_meta() /Users/manou/manou.io/projects/LBWWW/lbwww-new/app/public/wp-admin/admin-header.php:259
    [03-Apr-2020 15:37:30 UTC] PHP 4. apply_filters_deprecated() /Users/manou/manou.io/projects/LBWWW/lbwww-new/app/public/wp-admin/includes/class-wp-screen.php:823
    [03-Apr-2020 15:37:30 UTC] PHP 5. _deprecated_hook() /Users/manou/manou.io/projects/LBWWW/lbwww-new/app/public/wp-includes/plugin.php:631
    [03-Apr-2020 15:37:30 UTC] PHP 6. trigger_error() /Users/manou/manou.io/projects/LBWWW/lbwww-new/app/public/wp-includes/functions.php:5088

    And Affiliates Pro (v4.5.0) is using the hook in lib/core/wp-init.php line 1948

    Greetings

  4. George April 3, 2020 at 3:00 pm #

    Hi Daniel,

    Thanks for choosing our plugin for your affiliates program.

    Can you please send us a copy of the full stack for this deprecation notice from your debug.log? This hook is not used in Affiliates plugin and I assume that simply it is affected by another plugin that is using it, but just in case something is wrong on our side, it’s better to have a closer look at the log for this.

    Kind regards,
    George

We use cookies to optimize your experience on our site and assume you're OK with that if you stay.
OK, hide this message.

AffiliatesContactJobsTerms & ConditionsPrivacy PolicyDocumentationDownloadsUseful PluginsMy Account

Share