Affiliates which are also Woocommerce Customers – No content

Posted in

Hey,

we have Woocommerce customers with their login credentials there.
But if we add them (manually) also as an affiliate partner with their username they cannot see the their affiliate content on the affiliate partner site which was generated automatically.

How should we do? Meaning: They must see their Woocommerce Orders as well as theier Affiliate earnings.

Best regards,
Robert

9 Responses to Affiliates which are also Woocommerce Customers – No content

  1. George March 21, 2017 at 4:27 pm #

    Sure thing Robert.

    I will mark the topic as resolved so if you need further assistance you can submit a new topic.

    Cheers,
    George

  2. Robert March 15, 2017 at 9:37 am #

    Hi George,

    thanks for the extended description.

    Our setup seams to be correct – we will observe the next weeks and come back to you if needed.

    Thanks a lot and have a great day!
    Robert

  3. George March 15, 2017 at 8:58 am #

    No worries Robert. 馃檪

    Regarding your affiliate.
    So far, we haven’t got any reports indicating that WP Rocket is blocking affiliate URLs. Also, i haven’t noticed any issues with WP Rocket when i test other customers’ installations.

    First of all, place a test order using the affiliate’s link.
    If a referral is recorded, Pending or Accepted, then either the affiliate hasn’t referred orders(ie doesn’t promote the right affiliate URL), or the cookie has expired before the order was placed (aka Referral timeout setting).
    If a referral is not recorded, repeat the test using a new test affiliate, with your credentials.

    If the referral is still not recorded, please have a look at these suggestions, in case you are missing something.

    Make sure that the affiliate is Accepted under Affiliates > Manage Affiliates, Edit the affiliate.

    Make sure that Affiliates WooCommerce Integration is installed and activated.

    Depending on your setup, please check once more your commission settings. Under Affiliates > Settings > Commissions, check your option if you are using Referral Rate or Referral Amount with a numeric value on the second field, or Referral Amount Method with Affiliates_WC_Method::product_rates on the second field.

    If you use Affiliates_WC_Method::product_rates for commissions, have a look under Affiliates WooCommerce Integration, in case you didn’t set the default rate and no individual product rates.

    Check the products referred by this affiliate, in case you set a zero(0) product rate so they are excluded from commissions.

    If the above settings are normal and still you don’t get any referrals recorded from any of your affiliates, please let me know and i will review your installation.

    Kind regards,
    George

  4. Robert March 14, 2017 at 8:17 pm #

    Hi George,

    I’m so sorry for being an idiot 馃槈
    I testet with an user but didn’t add this user as affiliate – my fault. grrrrrr
    Everything works fine!! Thank you very much.

    Yes we know that affiliates are not added automatically – and that’s good for us.

    Maybe you can answer me another question please:
    An affiliate tells us that he is very very active but doesn’t get referrals.
    Could there be a problem with caching tools and your affiliate plugin? We are using wprocket for caching. Any experience or recommendations?

    Kindest regards and sorry again,
    Robert

  5. George March 13, 2017 at 4:48 pm #

    Hi Robert,

    Thanks for sending me access to your site. 馃檪

    Once i added myself as an affiliate, i can normally see the partnerbereich page.
    You can use my credentials to see the results.

    Please note that a new user or WooCommerce customer doesn’t become an affiliate automatically. If you prefer this to apply automatically, then you should have a look at Affiliates Users premium plugin.

    When you add a new affiliate manually, you should go to Affiliates > Manage Affiliates and press the New Affiliate button. There, for an existing user, you can only add a Name and an existing username and save. For non-existing users you should also add a valid email address.

    Kind regards,
    George

  6. Robert March 13, 2017 at 12:31 pm #

    Hi George,

    I did it again an generated the site https://www.checkbilliard.com/en/partnerbereich/ (I didn’t rename it to English like /partner-area/ to keep it default – we are in Austria with German language)

    But it still doesn’t work!

    I made an admin account for you @ https://www.checkbilliard.com/wp-login.php
    UID: george@itthinx.com PW: ittgeorge99

    BE SAFE!!! It’s a life System!!

    Thanks,
    Robert

  7. George March 11, 2017 at 3:06 pm #

    Hi Robert,

    You are welcome.

    This one sounds like an issue with the Affiliate Area page, probably a misplaced shortcode.
    Try to generate a new affiliate area page through Affiliates > Settings > Pages(tab) and try logging in the new page as affiliate. If the issue still persists, please send me temporary admin access to george at itthinx dot com, so that i can have a look at it.

    Cheers,
    George

  8. Robert March 10, 2017 at 9:29 am #

    Hi George,

    thanks for the quick response!

    I checked this points and everything is fine: Status: Accepted(active); Username OK; Clicking on Username redirects to users profile.

    What we did:
    We added manually the affiiate partners (no self registration allowed) and used the same email address as they use in their Woocommerce/Wordpress account – but without a user name (!).
    On the affiliate partners side the login form comes up. But if they login, the site says “Please log in to access the affiliate area.”, but they are logged in and can access their Woocommerce user/customer account.

    Info:
    We are using the BeTheme by Themeforrest/CodeCayon

    Thanks for advice,
    Robert

  9. George March 10, 2017 at 8:35 am #

    Hi Robert,

    Please do these checks and see if the problem is resolved.
    Visit Affiliates > Manage Affiliates and check your new affiliates one-by-one if they are Accepted or Pending. Also, check if each affiliate’s username is displayed properly, without an exclamation mark [!] and that if you click that username, you are redirected to the Edit Profile page for that user.

    Kind regards,
    George

We use cookies to optimize your experience on our site and assume you're OK with that if you stay.
OK, hide this message.

AffiliatesContactJobsTerms & ConditionsPrivacy PolicyDocumentationDownloadsUseful PluginsMy Account

Share