No Password Field on Registration?

Posted in

Using the shortcode [affiliates_registration] there is no field for password. After registering, the “Affilate Area” page which is recommended says “login here”. The login requires username and password??? Off course I can set the password in the backend, but what is the use of this? I want affiliates to be able to register and use the site. Also a message appears stating “check your email” however no email has arrived and all setting are correct? Do this sound like I need to re-install? the affiliates area page is showing as – the -2 looks like a second installation but I did run the deactivation of standard affiliates with deactivation set to delete all plugin data?? I am kind of getting frustrated here! 2 hours and no progress, just 1 screen which does not work!

8 Responses to No Password Field on Registration?

  1. ferky May 7, 2013 at 5:34 pm #

    Hi there…

    Is there anyway we can add that to the profile update page on the main site? Would be neater …

    Thank you

    • antonio May 8, 2013 at 6:26 am #

      you must use an external plugin for this purpose. Here is an article that looks interesting.

  2. ferky May 7, 2013 at 12:47 pm #

    Back to the Password issue, surely after the affiliate has received the password, they should be able to change it to something more memorable in the profile page. How can this be achieved??

    Many thanks

  3. ja1nsa April 19, 2013 at 10:08 am #

    Kento – thanks that fixed my problem. Nothing to do with your software – apologies! Was the Catch All account on my server, I had not set it up – oops!

    Many Thanks

  4. kento April 17, 2013 at 12:56 pm #


    The affiliate area you have on the site shows both the login form and the registration form correctly, I suppose you have enabled registration by now (you did get the ‘Registration is currently closed’ because it was disabled before).

    The login form is for affiliates, they receive their password after they have successfully registered using the registration form in the lower part of the page.

    If you do not receive the confirmation email after registering, these are possible causes:

    – it ended up in your spam/junk email folder
    – your site does not send the emails correctly or is not configured appropriately
    – you have disabled confirmation emails (or a plugin is interfering)
    – your email server is blacklisted

    I’ve tried to register but haven’t received the confirmation email and it’s not in the spam folder either, so that leaves an incorrect configuration or another plugin messing with emails sent.

    I would recommend to use the WP Mail SMTP plugin – see – which allows you to send a test email.

    And about the URL you can easily change that right at the top of the page when you edit the page in WordPress.


    • instanticon April 17, 2013 at 6:31 pm #

      Hi, I’m not sure where to post questions, but this is related to the registration form..

      1. Can you tell me where the file for the registration form is so that I can change the word “website” to Phone Number?

      I realize that this registers in the backend under the website field, but I’m not sure if there’s a better way to collect the affiliates phone number when they register.

      2. Is there a way to configure the “look” of the form?


      • antonio April 19, 2013 at 10:00 am #

        You can change this word in language file (wp-content/plugins/affiliates-pro/lib/core/language).
        But maybe you need use a plugin to customize wordpress registration form (more info).
        Also, you can setup the affiliate profile page


We use cookies to optimize your experience on our site and assume you're OK with that if you stay.
OK, hide this message.

Affiliates · Contact · Jobs · Terms & Conditions · Privacy Policy · Documentation · Downloads · Useful Plugins · My Account