not tracking subscriptions

Posted in

I’ve noticed that woocommerce subscriptions orders stopped tracking in November.
Your team confirmed my settings are correct and the plugin is up to date, what is the next step in resolving this issue?

18 Responses to not tracking subscriptions

  1. George January 30, 2017 at 10:50 am #

    Hi Jerry,

    Perhaps it was my mistake that i couldn’t login to the staging site.
    I have disabled almost everything on your staging site, so you have nothing to worry.
    In case you need to refund, please have a look here at WooCommerce documentation.

    Cheers
    George

  2. Jerry January 27, 2017 at 12:25 pm #

    Thank you for your reply and for noticing the problem.
    Once the a affiliates for woocommerce plugin is is updated everything will be in working order?
    How long have the antonioitt account not had admin access?
    We’re you able to do all your testing without access?
    Do you need me to give you access again to take care of the staging site?
    Lastly, no huge rush, just curious when the affiliates for woocommerce plugin might be complete.
    Thank you so much for your assistance and almost getting this thing ironed out.
    I really appreciate it!

    • Jerry January 27, 2017 at 12:30 pm #

      Oh yeah, and about the duplicate subscription charge, only 2 customers have been charged by the staging site so far.
      They were both paypal subscribers
      I will see if there is a way to revoke paypal authorization on the staging site site unless you have any suggestions.
      Thank you!
      Jerry

  3. George January 27, 2017 at 10:27 am #

    Hi Jerry,

    Thank you for being patient.

    There was an error with Affiliates WooCommerce integration, so as soon as the patch is applied and the new version is released, you will receive a notification on your Dashboard to update.

    The staging site is a totally different site and for the transactions made there, I was the affiliate and the buyer. Furthermore, there was no real charge or payment, once the checkout redirects to PayPal, my transaction stops and i simply change manually the order status from Pending Payment to Complete. For your own safety, you can also deactivate WooCommerce in the staging site, since i don’t have access anymore.

    Cheers,
    George

  4. Jerry January 24, 2017 at 5:03 am #

    Great news George!

    My host is Siteground who does not use Varnish Cache
    There are quite a few issues in the debug.log however I don’t think they apply to this issue. Here is the URL
    https://protectivediet.com/wp-content/debug.log

    Here is the url for the staged site (So excited they were able to get it to work finally)
    https://staging1.protectivediet.com/

    hopefully you can get the plugin working properly now that you have a staged version to work with
    馃檪

    • Jerry January 25, 2017 at 10:30 pm #

      Thank you for your help so far.
      Any ETA on getting the plugin to work?
      If possible I would like it to be resolved prior to February 1, 2017
      Is that goal attainable?

  5. George January 23, 2017 at 10:44 am #

    Hi Jerry,

    Sorry still investigating.
    In case your host is WP Engine please have a look here, or if your server uses Varnish Cache please have a look here.

    If there is anything logged in your debug.log file please forward it to george at itthinx dot com.
    First, try reinstalling Affiliates Pro and Affiliates WooCommerce Integration.
    Please keep in mind NOT to check the option under Affiliates > Settings to delete data upon plugin deactivation.
    If this doesn’t do the trick, it’s better to create a staging site so that i can modify it without hesitation. Some hosts offer that option to automatically create a staging site in a subdomain. Otherwise, you can create a new WP installation and copy your Database through phpmyadmin.

    Cheers,
    George

    • Jerry January 26, 2017 at 9:42 pm #

      Some of my customers have been double charged. I think the staging site is charging them as well as the live site. Please stop that if possible.

  6. Jerry January 22, 2017 at 6:19 pm #

    Hi George,

    Writing to find out how your testing is going. Also I awoke today with an idea for a possible solution…
    have you tried exporting all the history and deleting the plugin and all its data before installing the plugin and restoring the data?
    I tried disabling and deleting the plugin, but I am not sure how to delete all data and restore it successfully.
    I could be wrong, but I feel the issue with the plugin may lie in the database so doing a clean wipe/restore might resolve it.

  7. George January 20, 2017 at 9:13 am #

    Ok thanks for notifying me about emails Jerry. 馃檪

    I will carry on with the tests and let you know.

    Cheers,
    George

  8. Jerry January 17, 2017 at 10:41 pm #

    Hi George,

    I just reviewed your email. Please see my responses and let me know if you need me to restore admin credentials
    It seems we’re almost there. Thank you for your attention and assistance.

    Jerry

  9. George January 16, 2017 at 12:49 pm #

    Hi Jerry,

    Thanks for sharing.
    I have sent you instructions by mail on how to proceed with the url issue.
    The referrals though are recorded properly.

    Cheers,
    George

    • Jerry January 19, 2017 at 6:52 pm #

      All the emails I’ve sent you are bouncing back for some reason. Can you fix this so we may communicate via email? In the meantime, I restored your admin credentials.
      Please do not change the theme because the site is live and I’ve already tested it. Changing the theme resets settings of the widgets_on_pages plugin and would be detrimental to the site plus cause me a lot of work to restore again.

  10. Jerry January 15, 2017 at 8:08 pm #

    I meant to comment I just sent you an email with admin credentials.
    Thanks for getting to the bottom of this.
    Please let me know if there’s anything more you need from me.

  11. Jerry January 15, 2017 at 6:15 pm #

    I just replied, thanks George

  12. George January 15, 2017 at 5:51 pm #

    Hi Jerry,

    Regarding the link issue, reset your Permalinks. Visit your Dashboard and under Settings > Permalinks choose the default option and save. After saving choose your old option and save again. Also, make sure you are not using any redirection plugins that might be causing this issue.

    Regarding your referrals, i think it’s better to have a look in your configuration. Please send me temporary admin access to george at itthinx dot com.

    Kind regards,
    George

  13. Jerry January 15, 2017 at 5:17 pm #

    Hi George,

    Thanks for the reply.
    The are marked as processed and the recurring referrals box is ticked

    Also, visiting https://protectivediet.com?affiliate=10
    redirects to
    https://protectivediet.com/?affiliate=10
    which shows up as the most recent post rather than my home page.

    I am looking forward to resolving this. Thank you for your assistance.
    What trouble shooting would you recommend next?

  14. George January 15, 2017 at 4:49 pm #

    Hi Jerry,

    Please have a look at the affiliates you used in case they are pending. You can check that through Affiliates > Manage Affiliates if you edit the desired affiliate.
    Also, if you are using Affiliates Permanent make a test purchase with all options enabled.

    Regarding recurring referrals, if you are using WooCommerce Subscriptions plugin, there is an option for enabling recurring referrals under Affiliates > WooCommerce Integration.

    Kind regards,
    George

We use cookies to optimize your experience on our site and assume you're OK with that if you stay.
OK, hide this message.

AffiliatesContactJobsTerms & ConditionsPrivacy PolicyDocumentationDownloadsUseful PluginsMy Account

Share