Site crashed and scrambled!!!


Regarding and the affliiates enterprise we are using with it. We are doing a restore right now that hopefully works but our site crashed tonight with an http 500 error. we checked with host and they said it was the affiliates enterprise plugin causing the problem so they shut it off and the site would load again but everything was scrambled… like graphics missing and news was the home page now and can’t login to backend. Your plugin was up to date but WP was not. Also, It may have crashed around same time as a UpDraft backup was running – not sure if there is any conncection. This is very concerning. Can you shed any light on this as to the cause? We have liked being able to use your plugin but this is scary. Appreciate your help and input.

3 Responses to Site crashed and scrambled!!!

  1. George March 21, 2017 at 4:40 pm #

    Hi Jason,

    Sorry for the late response.

    Try to enable WP debugging and do the tasks that follow.
    In order to enable debugging, edit your wp-config.php file and replace the following line:
    define(‘WP_DEBUG’, false);
    with these lines:
    define(‘WP_DEBUG’, true);
    define(‘WP_DEBUG_LOG’, true);
    after that add a file named debug.log under your wp-content folder.

    If you haven’t already done it, try to debug your plugins. Deactivate all your plugins and then activate them one at a time until you get the 500 error.
    If this test was successful, try to switch to a default theme like twenty sixteen and check if you get the error.

    When performing the actions i mentioned keep checking your wp-debug.log file in case there are issues logged.


  2. Jason March 11, 2017 at 10:23 pm #

    It was set to…

    define( ‘WP_MEMORY_LIMIT’, ‘256M’ );

    Can you add more insight? Any known issues? this was a major crash and we had to do a restore. We would like to turn on affiliates again but would like to know the issue and fix it first. BTW. at the time, I believe all plugins and woo were up to date however WP itself was still running at 4.4.8 and AVADA theme was also older. we have been bringing things up to date. this past week.

  3. George March 10, 2017 at 8:18 am #

    Hi Jason,

    One of the reasons for a 500 Error is when php memory is exhausted. The allocated memory is not enough to run all your plugins smoothly. To be certain for that, try adding a few more plugins on your site and keep affiliates plugin deactivated.

    If you have access to php.ini set the memory allocation to 128 like this:
    memory_limit = 128M;
    If on the other hand, you don’t have access to php.ini, you can add the following to your wp-config.php file:
    define(‘WP_MEMORY_LIMIT’, ‘128M’);

    Kind regards,

We use cookies to optimize your experience on our site and assume you're OK with that if you stay.
OK, hide this message.

Affiliates · Contact · Jobs · Terms & Conditions · Privacy Policy · Documentation · Downloads · Useful Plugins · My Account