User registration is not working

Posted in

Hello,
I have a problem with the user registration when someone registrates to the Affiliate program through the built-in user registration form, the formidable form or the Ninja form. I properly created the forms through the mentioned plugins according to your documentation but I have not solved the problem.

1) The built-in registration form is not working totally. The user does not receive any confirmation and as the admin don’t receive any confirmation email as well. The new user and the new affiliate is not created automatically through this registration form.
2) The Ninja form is somehow better. The admin receives the confirmation email but the user not. The new user and the new affiliate are not created automatically through this registration form.
3) The Formidable is the best of them, all the user and admin receive the confirmation emails but the new user and the new affiliate are not automatically created as well.

Is the Affiliate Pro missing any Addon or plugin? or I have to upgrade to Affiliate Enterprise to have the automatical creation of a new affiliate/users through the above kinds of registration forms.

Thank you for answer.

6 Responses to User registration is not working

  1. antonio December 8, 2017 at 12:45 pm #

    Hi DO,
    Please check:
    – If the user registration is open from Settings->General (“Anyone can register” option)
    – If the affiliates registration is enabled from Affiliates->Settings:Registration.
    If the options are enabled and the problem persists, please send me dashboard admin access to antonio[at]itthinx[dot]com indicating this topic, and I’ll have a look at your settings.
    Kind Regards,
    Antonio B.

  2. DO December 8, 2017 at 2:32 pm #

    Hi Antonio,
    I have all the settings correct but it is still not working.
    I have sent you an email with the admin access information.
    Thank you for your support.

    • antonio December 8, 2017 at 6:11 pm #

      Thanks,
      Answered by email.
      Kind Regards,
      Antonio B.

  3. DO December 8, 2017 at 9:21 pm #

    Hi Antonio,
    thanks for testing, the affiliate-area-7 that you have tested was created together with the Formidable Form plugin. The message you get means “the application for the affiliate program is accepted and waiting for approval” (I just translated this message from the default message in Formidable form plugin settings, in which I already set up the default for new register status is ACTIVE, no pending or waiting for approval). I don’t install any plugin or option for approving new WordPress users. I tried to deactivate most of the plugins that are not involving the Affiliates Pro plugin and tried the registration for the affiliate program again. I also tried to reinstall the Affiliates Pro plugin as well but it did not help. 馃檨
    Thanks for the assistance.

    Best regards,

    Duc Linh Do

  4. DO December 9, 2017 at 12:26 pm #

    Hi,
    I have solved the problem. It was a conflict of the Affiliates Pro with the plugin “Affiliates Contact Form 7 Integration”. When I deleted this plugin, the affiliate pro runs perfectly. Thanks.
    Do.

    • antonio December 11, 2017 at 3:55 pm #

      I’m glad you’ve solved it.
      Kind Regards,
      Antonio B.

Share